Home

Hello,

 

So my new Ribble Aero 883 arrived and had Mavic Cosmic Pro Carbon SL UST Disc on, I have added some sealent, not sure how much in Millilitres? Also my rear keeps deflating, vry slowly but noticably over a day. I have deflated and repopped the tyre bead back on, I am putting roughly 60psi into them, is this too little? Any advice or help would be appreicated

5 comments

Avatar
Nat Jas Moe [196 posts] 4 months ago
0 likes

to seat them initially I inflate to tyre maximum. Then deflate to what I ride at normally. As far as how much 30 - 60 ml depending on terrain. I would also check that your valve is nice a tightly seated as that's where I had a leak when I first went tubeless.

Avatar
Jimthebikeguy.com [267 posts] 4 months ago
0 likes

Ensure they are seated by inflating hard and fast, a compressor helps. Go high on pressures. Then add sealant, about 40-50ml. Now take the wheel, hold it in two hands at 3 and 9, ajd shake it, rotate a bit, shake, rotate, etc. You are trying to work the sealant up inside the tire wall. Finish at the valve, and shake very vigorously. Then put the wheel flat, rotate slowly. Flip over, repeat. If it goes down, repeat. If it keeps going down, submerge in water to see if it leaking at the valve. If so add maybe 10ml more sealant and ensure you shake it over the valve again.

Avatar
mancsi [107 posts] 4 months ago
0 likes

Thank you! I will do this tonight, I checked the tyre and it was flat again this morning. I will go through this process and let you know what happens

Avatar
Spangly Shiny [269 posts] 4 months ago
0 likes

If all else fails try mounting the tyres initially using some car tyre bead sealer, like this:

https://www.tyrebaydirect.com/product/bead-sealer-950ml/

Avatar
bigbiker101 [67 posts] 4 months ago
0 likes

If the Rim tape isn't seated perfectly this will also leak, I had to replace the Rim tape on one of my Hunts due to slow leaks