First post here. I have replaced my Mio Cyclo 315 with a 405 and have realised they both have an idential software fault. I only checked on my 315 when it became apparent the 405 had a problem.

The problem is that the device will record from you turn it on, not from when you press the record button. Sometimes it will add a long period of nothing-ness to the beginning of the recording even though the device wasn't even on.

Mio says no-one else has complained and they have tried to replicate it on two of their devices but can't. They have assigned me an RMA and I will send the 405 in for repair.

I know Mio isn't very popular (too big?) but just wondering if anyone here use Mio Cyclos and have had a similar problem?



morsing [2 posts] 3 months ago


I have received a replacement device (they claim the mainboard was replaced) and it has the same fault. I'm quite convinced this is a world wide software fault but as almost no-one use Mio devices and the few that does probably haven't spotted the problem or reported it, it's hard to convince them. I am waiting for a reply.

morsing [2 posts] 2 months ago



Last follow-up - I have received a replacement device, same fault, now one 315 and three 405 displaying this.

I had a look aournd the settings on the device, and found on both hidden away something called "Auto Recording". This is not mentioned in the manual at all.

Disabling this fixed it. 

I'm very disappointed at the incompetence of Mio. Their support staff doesn't know about this, their technical repair center doesn't know about it, and their software engineers working on the software doesn't know about this.

Great. At least it works now.