Support road.cc

Like this site? Help us to make it better.

forum

Video Ads with blaring sound

I remember when I was a subscriber, Road.cc decided to add the auto play feature for their videos with ads on all articles which was annoying at the time. Did they remove them for subs in the end? 

Only asking as the silent videos that start advertising their videos silently stop being silent between 30 secs and a 1minute into browsing with a 30 second long Olivia Rodrygo (whoever she is) advert. Obviously a pain when doing a quick browse on a works laptop with built in speakers. Shame I can't install Ad-blockers so less vists to road.cc is on the horizon. 

If you're new please join in and if you have questions pop them below and the forum regulars will answer as best we can.

Add new comment

16 comments

Avatar
Eton Rifle | 453 posts | 4 days ago
2 likes

Currently logged in as a subscriber. Why am I bothering to pay a subscription when I STILL have to put up with annoying adverts?

Avatar
Sriracha | 4087 posts | 5 days ago
5 likes

I get the feeling the whole edifice is creaking under the strain. The underpinnings of the site need a full overhaul:

Comments section doesn't thread the posts in some long threads,

No proper integration with sister sites, can't even copy across the comment count,

No search facility, near impossible to find older pages, no way to find one's own previous comments (maybe not a bad thing!)

Whole site has now near-as ground to a halt, massive page load times, 502 bad gateway errors etc,

Double posts have returned, so has AJAX 504 etc, edits don't stick, takes forever to post a comment, even to like a comment!

I'm sure there's more.

I don't suppose it's easy working under the bonnet, but somebody's go to know how.

Avatar
chrisonatrike replied to Sriracha | 6811 posts | 5 days ago
2 likes

I think it's been gnawed away from within, possibly sapped by too many (not very well hidden) nuts.

Avatar
hawkinspeter replied to chrisonatrike | 12190 posts | 5 days ago
2 likes

chrisonatrike wrote:

I think it's been gnawed away from within, possibly sapped by too many (not very well hidden) nuts.

Avatar
andystow | 1180 posts | 5 days ago
4 likes

No sound, but I'm currently seeing a pop-over Go-Daddy ad about every 20 seconds despite being logged in as a subscriber. I'm going to try logging off and back on again.

Avatar
andystow replied to andystow | 1180 posts | 5 days ago
1 like

Didn't help.

Avatar
HoldingOn replied to andystow | 448 posts | 5 days ago
1 like

I really hope the site issues they have been having over the last few days isn't down to a code change to push adverts to subscribers!

Avatar
hawkinspeter replied to HoldingOn | 12190 posts | 5 days ago
1 like

HoldingOn wrote:

I really hope the site issues they have been having over the last few days isn't down to a code change to push adverts to subscribers!

I doubt it as I've got my browser to ignore as many ads as possible, so that wouldn't be slowing me down (haven't noticed new ads appearing either).

Avatar
peted76 | 2529 posts | 1 week ago
0 likes

Subscriber here, I haven't seen this issue. 

Avatar
Rendel Harris replied to peted76 | 5442 posts | 1 week ago
0 likes

peted76 wrote:

Subscriber here, I haven't seen this issue. 

Seems to have been fixed now, not happened since Sunday.

Avatar
Rendel Harris | 5442 posts | 1 week ago
3 likes

Subscriber and had this several times in the last few days, vastly annoying music, was not popular at seven this morning when I opened the site on the computer then went to make pre-ride coffee only for it to suddenly start blasting out!

Avatar
HoldingOn | 448 posts | 1 week ago
0 likes

I subscribe - I don't see any adverts at all and none of the embedded videos in news stories autoplay (the X/YouTube/Instagram videos)

Avatar
AlsoSomniloquism replied to HoldingOn | 4331 posts | 1 week ago
0 likes

Check out if you can see the Road.cc youtube video halfway down any article (also check to see if you already have an adblocker on and working as it does block this as well.). 

The adverts are normally muted at the start, the the Road.cc video will play a couple of minutes of one, then auto change to another road.cc one. On each change a couple of adverts play and for some reason, the Olivia Rodrygo is / was unmuted and blared out her music loudly. It is not the first time this has happened, but is definitely the most annoying and loud one to have happened. 

However It might have either been removed from rotation by Road.cc or just no longer needed as time sensitive as it isn't appearing this evening. 

Avatar
HoldingOn replied to AlsoSomniloquism | 448 posts | 1 week ago
0 likes

screenshot logged in, looking at a random article

Avatar
HoldingOn replied to HoldingOn | 448 posts | 1 week ago
0 likes

same article, not logged in

Avatar
AlsoSomniloquism replied to HoldingOn | 4331 posts | 1 week ago
1 like

It is that video box in the centre which was the culprit, especially with the one shitty advert which didn't auto mute. So it seems they have now removed them from subscribers. If they were faster at getting rid of known PBU's I might resubscribe at some point.

Latest Comments